Precision, Performance, Confidence. ™

How to use a domain account instead of a machine account to configure MET/TEAM, Customer Portal and Alerting

Below is an outline of the steps needed to configure MET/TEAM, Customer Portal and Email alerts to use a domain windows account instead of the default of a machine account.

  1. In IIS, stop the MET/TEAM and Customer Portal sites
  2. In windows services, stop the “Fluke MET/TEAM Email Alerts Engine” service
  3. Verify the MET/TEAM and Customer Portal Web.config files have correct connection strings (typically this is fine)
  4. Back in IIS to click Application pools
  5. In "Application pools" pane, select  METTEAM
  6. In the “Actions” panel on the right, click "Stop" under Application Pool Tasks
  7. On the right, under "Edit Application Pool", click Advanced Settings
  8. In the Advanced Settings window, click Identity and then the ellipsis [...]
  9. In the "Application Pool Identity" pop up, select the “Custom Account” radio button
  10. Click "Set..." button and enter necessary info to use desired windows account
  11. In the "Set Credentials" pop up, click "OK" and it will close
  12. In the "Application Pool Identity" pop up, click "OK" and it will close
  13. In the "Advanced Settings" pop up, click "OK" and it will close
  14. Back in IIS manager, in the “Actions” panel on the right, click "Start" under Application Pool Tasks
  15. Next click "Recycle.." on the right (typically there is no indication anything happens)
  16. Make sure App pool is started as indicated by the "Start" option being disabled
  17. Restart the web site
  18. Log into the web site and verify it is working
  19. Repeat steps 4 thru 18 for "METTEAM Customer Portal" instead of "METTEAM"
  20. In the Registry, verify the following entry is correct (very similar to info in web.config, verify server, database and website entries are correct)
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\EmailAlerts\ImagePath
  21. Now in "Local Services", click to view the properties of the “Fluke MET/TEAM Email Alerts Engine” service
  22. Use the “Log On” tab to configure the same account as above to be for running the service.
  23. Re-start the “Fluke MET/TEAM Email Alerts Engine” service
  24. Verify it starts
  25. Test alerting to see that reports are successfully sent.

The issue should be resolved at this point if not contact softwaresupport@flukecal.com for further assistance.

Have more questions? Submit a request

Comments

Please sign in to leave a comment.