Precision, Performance, Confidence. ™

How to create a new procedure project, procedure and PXE

Getting started with MET/CAL Editor can be a bit intimidating.  "What do I do at this blank screen?".

Ultimately, the goal is to create a procedure that is executable in MET/CAL Runtime or from a work order in MET/TEAM.  

Open the Editor.  First let's set a default location for any new projects you create.  Nothing is more frustrating than creating a project and then losing it somewhere in the PC or Network. 

Click the "Tools" menu and then "Options".  Once you see the options menu, select "Projects and Solutions".  The path we want to modify is the first one.

Click the Ellipses (the three little dots) and choose a location where you want to store project folders - then confirm by clicking OK. 

Next, we'll start building the procedure.

Click on the "File" menu.

Specifically File>New>Project.  This will bring up the New Project window.  You can edit the Name field.  For now, let's just leave the solution defaults as is.  (Note the solution will have the same name you gave the project).

You should now see the project you just created in your Solution Explorer section of the Editor window. 

Once you have your project created you can add new items, like a newly-written procedure file, or existing items, like pictures to your project.  

To add, I like to right-click the project (the project will be in bold type) in the solution explorer and click "add".  Alternately you can use PROJECT on the menu bar.

Let's add a new item, and select MET/CAL Procedure.

Now the Name in the window above is a file name.  We will still have to give the procedure a "real" name by editing the INSTRUMENT: line in the procedure.  Feel free to leave the default name or give the file a new name (this can be changed later). 

Now that you have a new procedure added to your project, you can add an Instrument line name and write your procedure. 

You can also use the "add" menu for adding pictures, sub procedures and any other file this project needs.  (I added a .bmp file seen below)

 

 

When you have finished writing and compiling your procedure, click on the project in the Solution Explorer.  Selecting the menu BUILDPublish Package... will create a PXE file and a project zip (for archiving).  It will also give you an opportunity to save the PXE in another location:

 

If this is a "released" procedure and you want other people to have the ability to run it, save it somewhere accessible to everyone.  

Procedure writing will take more than one article to cover completely.  As a matter of fact, Fluke offers classes.  You can look here if you are interested.  

Fluke Calibration Software Classes

For more information, contact softwaresupport@flukecal.com

 

 

Have more questions? Submit a request

Comments

Please sign in to leave a comment.