Precision, Performance, Confidence. ™

How to Convert PROC.DIR to PXE using MET/CAL Editor

If you are migrating/upgrading to MET/TEAM or MET/CONNECT for the first time from MET/TRACK used with MET/CAL, or if you are upgrading an older version of MET/TEAM used with MET/CAL you may need to convert your old *.pro procedure procedure directory files into procedure executables, known as PXE files.  These PXE files are the only files that can be run from MET/CAL Runtime from MET/CAL version 9.1 and later.  

 

There are two ways to do this. 

1 - File>New>Project from existing procedure and

2 - Tools>Convert PROC.DIR to PXE

Choosing the one that works for you depends on how "clean" your proc.dir files are and whether or not you want to take all of your procedures with you.

Method 1 - File>New>Project from existing procedure

This method will allow you to select individual procedures and browse to different procedure directories to decide which ones you want to convert.

First review the health of your procedure directory

The following steps will make certain your procedure directories are in top shape prior to doing the conversion.  This will avoid many common errors and eliminate unneccessary trouble-shooting steps post-conversion.

What the conversion process will look for is the pics, and the user program directory.  It will look at the ini file from the machine you are running this on, so make sure those paths are correct and that the directories seem to contain the files you need.  

mceclip0.png


The proc directory you can point to from Editor.  just by selecting that proc.dir button.


A couple of helpful hints.

Click on the "exclude hidden procedures" button and search again.  Make certain ANYTHING that starts with SUB is hidden.

To check that, sort by "instrument" (just click on that bar in the window and it will sort) and make sure you don't see any subs.  If you do, just highlight them and click the "hide" button, otherwise you'll have a bunch of projects you don't need and that can't be built into PXE files.   (note, you can use shift + down arrow to select multiples) 

I also recommend after all that, that you "validate procedures on load" on each procedure directory.  If you get errors when you do that, follow this article. 

How to rebuild a corrupt Met/Cal procedure directory

Once you are finished doing any cleaning necessary, you just click File>New>Project from existing procedure , select the procedures you want to convert (or all of them) and follow the on-screen prompts until you have built all the PXEs you want.  

Or you can follow the instructions for using the Convert PROC.DIR to PXE from the Tools menu.  Again, it is highly recommended that you clean up your procedure directory prior to proceeding.

Steps to Use Convert PROC.DIR to PXE Tool found in MET/CAL Editor

  1. Create a PXE Files and Project Output folders  in your Shared Folder 
  2. Open MET/CAL Editor 
  3. Click on the Tools tab 
  4. Select Convert PROC.DIR to PXE blobid0.png
  5. On the Convert PROC.DIR to PXE page, Browse to both the Project Output Folder and PXE Output folders you craeted in Step One.  blobid4.png
  6. Now click “Browse” next to the “PROC.DIRs Found” section:  blobid5.png
  7. Now find your PROC.DIR. Click on the file location in the left pane, then click the “à” arrow so that PROC.DIR is Selected For Conversion blobid6.png
  8. If everything looks correct, then click “Convert” in the lower left corner. 
    blobid7.png
  9. Click “Ok” on the next warning window.  
  10. The process will start and show you an approximation of its progress.
  11. This system may then show you a screen that there may have been errors in the process.  blobid8.png
  12. MET/CAL Editor will then restart.
  13. Any errors that occurred in the process can be found and reviewed in the Project Output folder you created. 
  14. Your PXE’s can be found in the PXE folder you created. 
  15. Follow this article to see how to add and use these files in MET/TEAM:

Uploading PXE Procedures Into METTEAM After Migration

Have more questions? Submit a request

Comments

Please sign in to leave a comment.