0

Metcal Editor no longer working

My Editor is no longer functioning; it no longer displays the code nor allows me to make any changes. Whenever I open a solution I get the following error: "An exception has been encountered. This may be caused by an extension." It then gives me a log file to get more information.

When I look at the log file the error is "

System.IO.FileNotFoundException: Could not load file or assembly 'METCAL.Editor.Project, Version=8.3.2.3, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified. File name: 'METCAL.Editor.Project, Version=8.3.2.3, Culture=neutral, PublicKeyToken=null' at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) at System.Reflection.RuntimeAssembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) at System.Reflection.Assembly.Load(AssemblyName assemblyRef) at System.ComponentModel.Composition.Caching.TypeResolver.ResolveTypeRef(String assemblyName, Int32 metadataToken, Type[] genericArguments) at System.ComponentModel.Composition.Caching.TypeRef.get_Type() at System.ComponentModel.Composition.Caching.TypeRefList.<GetEnumerator>b__1(TypeRef typeRef) at System.Linq.Enumerable.WhereSelectListIterator`2.MoveNext() at Microsoft.VisualStudio.Text.Tagging.Implementation.TagAggregator`1.Match(IEnumerable`1 contentTypes, IEnumerable`1 tagTypes, IContentType bufferContentType) at Microsoft.VisualStudio.Text.Tagging.Implementation.TagAggregator`1.GatherTaggers(ITextBuffer textBuffer) at Microsoft.VisualStudio.Text.Tagging.Implementation.TagAggregator`1.<.ctor>b__0(ITextBuffer buffer) at Microsoft.VisualStudio.Text.Projection.Implementation.BufferGraph.GetTextBuffers(Predicate`1 match) at Microsoft.VisualStudio.Text.Tagging.Implementation.TagAggregator`1..ctor(TagAggregatorFactoryService factory, ITextView textView, IBufferGraph bufferGraph, TagAggregatorOptions options) at Microsoft.VisualStudio.Text.Tagging.Implementation.TagAggregatorFactoryService.CreateTagAggregator[T](ITextBuffer textBuffer, TagAggregatorOptions options) at Microsoft.VisualStudio.Text.Tagging.Implementation.TagAggregatorFactoryService.CreateTagAggregator[T](ITextBuffer textBuffer) at Fluke.Metcal.Editor.Project.Classification.METCALClassifierProvider.CreateTagger[T](ITextBuffer buffer) at Microsoft.VisualStudio.Text.Tagging.Implementation.TagAggregator`1.GatherTaggers(ITextBuffer textBuffer) WRN: Assembly binding logging is turned OFF. To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1. Note: There is some performance penalty associated with assembly bind failure logging. To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog]. "

Any help?

 

5 comments

Date Votes
0
Avatar
Michael Johnston

I would try uninstalling and reinstalling the editor first off. That will often fix issues that pop up without explanation.

If that doesn't work, I suggest emailing softwaresupport@flukecal.com to get in touch with the Software Support group. They'll be more than qualified to figure out the issue. I imagine though, that the first thing they'll suggest is a reinstall.

0
Avatar
Michael Sandel

Already tried the reinstall, but thanks. I will email them.

2
Avatar
Alan Cordner

msandel,

Were you able to get the Editor working again? If not, try this. There are some registry keys and folders in the file system that can sometimes become corrupted and will cause issues similar to what you are experiencing. Deleting these items will allow the Editor to recreate these settings and folders with default values. Any customized settings will need to be configured again.

Delete Registry Keys:

1) Run the application "regedit.exe"

2) Locate and delete the following keys (where "x.y" is the current version of MET/CAL, i.e. "8.3"):

  a) HKEY_CURRENT_USER\Software\Fluke\mce32\x.y

  b) HKEY_CURRENT_USER\Software\Fluke\mce32\x.y_Config

Delete File System Folders:

1) Open Windows Explorer or File Explorer

2) Locate and delete the following folders (where "x.y" is the current version of MET/CAL, i.e. "8.3" and "<user>" is your Windows user name):

  a) C:\Users\<user>\AppData\Local\Fluke\mce32\x.y

  b) C:\Users\<user>\AppData\Roaming\Fluke\mce32\x.y

Note that the AppData folder is a hidden folder. Configure Windows Explorer to show hidden folders or simply type/paste the path into the address bar.

0
Avatar
Herron, Jacob

I know this is old but does anybody know what triggers this error?

0
Avatar
Alan C.

Jacob,

As developers, we have observed that attempting to run different versions of MET/CAL Editor (v8.x, v9.x, etc.) on the same machine can cause this to happen. The MET/CAL Editor is based on the Microsoft Visual Studio Isolated Shell. If there are other applications running on the machine that are also based on the Microsoft Visual Studio shell, there is a potential that they could also cause this to happen. Beyond that, we have not been able to determine a precise cause of this issue.

Please sign in to leave a comment.