0

Using the Fluke 5730A in 5700A or 5720 Emulation Mode

I am using our new 5730A in emulation mode in place of our 5700 and 5720 calibrators in MetCal 7. I have managed to get it to work but am having occasional timeout errors that causes the 5730 to lock up and require a hard powerdown. Does anyone have any tips on how to correctly set up the configuration file and the NI Max communications which might be the cause of these errors? 

4 comments

Date Votes
0
Avatar
Chris Stampfli

Hey Mike,

The Problem is known.

Do you use the FSC 5720 Command or the SCPI [@5720]?
What Firmware do you use?

We noticed that it mainly occures with procedures that use SCPI [@5720] commands, that ran without any issues for a long time. A Firmwareupgrade seems to decrease the frequency of the error.

Best regards

Chris

0
Avatar
Dale Chaudiere

I truely hope that is a typo.  The 5720A is NOT SCPI compatible.  If you need to control the 5720 directly without using the 5720/M5720 FSCs, you should use the IEEE2 or IEEE FSC.  The only difference between the IEEE2 and SCPI FSCs is when an instrument error occurs and the instrument assets a Service Request (SRQ).  When an instrument error occurs using the SCPI FSC, "SYST:ERR?" is sent to the instrument.  This is NOT a valid 5720A remote command, which will cause the 5720A to asset another SRQ.  This may cause the SRQ line to be stuck high.

0
Avatar
Don Baumann

Mike has left us to take a position near his wife in Florida, so I'll respond that we are hoping it is not a Firmware issue as we just took delivery of them (on Friday, Oct. 3rd) brand new - direct from Fluke.  I'll have to check on the FSC versus SCPI (asserting an SRQ query).  I'm quite certain we configured it as a 5720, but not M5720.  Where are further details found?

Thanks!

Don

0
Avatar
James Smith

I have the same issue as well. We just got our in today (10/14/14). First thing I did was an ops check via automation and it locked up. Unfortunatly it locked up with the output on at 600V 60Hz. The 5730A would not respond to any buttons pushed with anything other than BEEP! I could not get a response via NI. I tried *CLS,*RST,*IDN? etc...j and all it would do is time out. This is really not good. I thought about testing to see if it would trip if i shorted the outputs, but did not want to run the possability of damaging the unit. We run most things here automated and to have a permant output of 600V with no way to turn it off except hard power off is a bit concerning. I was testing the 5720 FSC to see if the 5730 could easily be used in its place. When does Fluke plan on putting out the new firmware to fix this problem? And is it able to be downloaded and installed at our level? I have not tried IEEE or IEEE2 FSC yet. However, im sure I will probably get the same results. 

Please sign in to leave a comment.