0

Date Formatting

We have installed Met/Team 3 days ago, so I'm in a steep learning curve. On the Quote form, when I'm trying to save it, all dates are shown as errors. They are all in the American format of mm/dd/yyy where in Australia we use the format of dd/mm/yyy. This is also the default setting of my computer. Today's date is 24 January 2013 and is shown as 01/24/2013. When I change the date to read 01/04//2013 it is accepted by the system. (When I enter the date as 24/01/2013 it gets corrected by the system to read 12/01/2013). I encounter the same problem on the Work Order form.  Is there a solotion to the problem?

5 comments

Date Votes
0
Avatar
Kevin Griffis

The data type for these fields is DATETIME.  The Microsoft SQL Server format is "yyyy-mm-dd hh:mm:ss[.nnn]"  From what little I have learned about MS SQL Server, this is the native DATETIME format and there is no way to change it.  The Date and Time can be displayed differently, but this would be through the use of conversion functions that would have to be performed programatically for the GUI.  It appears that Fluke did not make provisions for displaying dates in any format other than mm/dd/yyyy.

I also find this bothersome, as I prefer a dd-mmm-yyyy format, to prevent any confusion between month and day. (For example, is 01/02/2014 01-Feb or 02-Jan?)  In the industry I am in, we see both formats dd/mm and mm/dd, depending on who we are doing business so, for the sake of clarity, in the calibration lab we use dd-mmm-yyyy.

I believe the solution to this problem will have to come from Fluke.

0
Avatar
Tony Carman

We had the same issue initially but Fluke released a new version last week that addresses this issue.  On our sytem the date format is now displayed correctly.

0
Avatar
Kevin Griffis

Tony,

Thanks for the heads up.  I've been checking the MetSupport site now and then, but hadn't seen this yet.  Downloading now.

0
Avatar
William (Bill) Spath

To work correctly with the English - Australia or English - New Zealand you will require MET/TEAM version 1.0.3.6 at a minimum.

 

0
Avatar
Douglas Fraser

All Data Time fields in MET/TEAM are stored in UTC (Coordinated Universal Time ), the MET/TEAM interface shows the UTC offset by the local computer clock settings.

However since the Crystal Reports reports directly from the database (not going through the MET/TEAM), the data is in UTC format. Therefore it needs to be shifted for the report to show local time.

The date format in Crystal Reports is set by right-clicking on the field and setting the format you want for the date field.

 

Please sign in to leave a comment.